飘云飘云

漂泊的云,停留的心!人的头脑太复杂,时间过得久,有时候连自己也被自己骗了,记下来才是最真实的……

Proxmox VE(Proxmox Virtual Environment)V5.3升级到Proxmox VE(Proxmox Virtual Environment)V5.4


升级前注意事项

在测试环境进行,无误后再到生产环境进行升级(没事别乱升级,除非万无一失)。
生产环境升级,一定要做好备份,万一奔溃了,还有机会重生。

更新准备

本过程仅需需改一下软件更新源,其操作为修改文件/etc/apt/sources.list,增加如下一行内容:

deb http://download.proxmox.com/debian  stretch pve-no-subscription
echo "deb http://download.proxmox.com/debian  stretch pve-no-subscription" >/etc/apt/sources.list

保存修改,并确定一下当前的proxmox VE版本号,命令为:

root@pve:/etc/apt# pveversion -v
proxmox-ve: 5.3-1 (running kernel:  4.15.18-9-pve)
pve-manager: 5.3-5 (running version:  5.3-5/97ae681d)
pve-kernel-4.15: 5.2-12
pve-kernel-4.15.18-9-pve: 4.15.18-30
corosync: 2.4.4-pve1
………省略……

01.jpg

执行更新

命令行执行 apt-get update && apt-get dist-upgrade ,留意一下输出,了解更新过程。

验证升级

命令行查看: pveversion –v,输出如下图所示。
02.jpg

Proxmox web管理后台查看。
03.jpg
从更新的输出,可以看到内核也有更新。为了启用新内核,可以考虑重启系统。在重启系统之前,先看看当前运行的系统内核:

root@piaoyun.cc:/etc/apt# uname -ar
Linux pve 4.15.18-9-pve #1 SMP PVE  4.15.18-30 (Thu, 15 Nov 2018 13:32:46 +0100) x86_64 GNU/Linux

重启系统,然后再检查内核版本号:

root@piaoyun.cc:~# uname -ar
Linux  pve 4.15.18-18-pve #1 SMP PVE 4.15.18-44 (Wed, 03 Jul 2019 11:19:13 +0200)  x86_64 GNU/Linux

由此可知,确实使用了新的内核。

当前页面:飘云 » Proxmox VE(Proxmox Virtual Environment)V5.3升级到Proxmox VE(Proxmox Virtual Environment)V5.4

评论